Comment faire un devis automatisé Excel ?

Créer un devis est une étape incontournable dans le processus de vente d’un travailleur indépendant ou d’un entrepreneur.
Marion Duvernoy
Publié le  
December 13, 2023
, mis à jour le  
December 13, 2023 8:00

Elle permet d’envoyer un signal de transparence et de clarté sur les transactions commerciales. Si la tâche peut sembler fastidieuse, l'utilisation d'Excel comme outil de création de devis simplifie le processus. Voyons comment faire un devis automatisé sur Excel.

Tutoriel : créer un devis automatisé avec Excel

Etablir un devis est une tâche chronophage qui entraîne parfois un risque d’erreurs d’inattention. Avant de commencer voici la liste des mentions obligatoires à ne pas oublier pour créer un devis conforme.

Mentions obligatoires d’un devis

Elles sont au nombre de 10 :

  • Date d’émission du devis
  • Durée de validité de l'offre
  • Coordonnées du prestataire (nom ou raison sociale / adresse / la mention « EI » après votre nom si vous êtes entrepreneur individuel)
  • Coordonnées du client (nom et adresse)
  • Description de chaque prestation proposée
  • Mode d'intervention proposé 
  • Prix horaire ou forfaitaire pour chaque prestation proposée
  • Si le prestataire est soumis à la TVA, le taux de TVA de chaque prestation
  • Montant total à payer ou montant total mensuel ou hebdomadaire, hors taxes (HT) et toutes taxes comprises (TTC)
  • Le montant détaillé de tous les frais annexe (HT et TTC: TTC), s’il y en a.

Ces mentions peuvent différer en fonction de votre activité. Pour plus d’informations, consultez le site du service public pour connaître les mentions supplémentaires.

Bon à savoir : Dans le cadre d’une relation entre professionnels, il n’est jamais obligatoire d’établir un devis. Il est toutefois conseillé d’en faire un dans la mesure où son acceptation engage juridiquement votre collaborateur sur le tarif annoncé.

Tutoriel pour créer un devis automatisé sur Excel

  1. Créer votre base clients

Dans la première feuille de calcul, incorporer les données relatives à vos clients en mentionnant leur nom, adresse, code postal (CP), ville, téléphone, e-mail et numéro client si besoin.

Renommer l’onglet « Client » et passer à l’onglet suivant.

  1. Créer une base « prestations »

Cette base sera constituée des colonnes suivantes : prestation, description, prix unitaire en €, taux de TVA (si vous facturez la TVA).

Nommez l’onglet « Prestations » et ouvrez une troisième feuille de calcul pour créer le modèle du devis.

  1. Créer le modèle devis

Nommez votre troisième onglet « Devis ».

Commencez par sélectionner une forme dans laquelle vous inscrirez « DEVIS » afin de matérialiser la nature du document : Insertion > Forme > Rectangle

Dessinez votre rectangle, personnalisez-le avec les couleurs et la police qui vous convient le mieux et positionnez-le en haut à droite.

Créez ensuite :

  • Les informations du devis : « Référence : », « Date : » et « N° du devis : », 
  • Les informations relatives à votre entreprise : « Nom de l’entreprise : », « Adresses / », « CP/Ville : », « Tel : », « E-mail : »
  • La partie informative concernant le client : pour reporter les données de la base créée précédemment de manière automatique, cliquez sur Données > Validation des données

Sélectionnez « Liste »

Cliquez ensuite sur l’icône du tableau avec la flèche rouge et sur l’onglet « Client » sélectionnez les noms de la colonne « Nom » de tous vos clients. Validez. Un menu déroulant vous permettant de les sélectionner apparaît.

Pour reporter l’adresse correspondante au client de manière automatique :

  • Sélectionnez la case du dessous puis écrivez =RECHERCHEV 
  • Ouvrez une parenthèse et sélectionnez la case cliente que nous venons de créer
  • Ajoutez « ; » et sélectionnez l’ensemble de la base de données clients en prenant soin de ne pas sélectionner les titres. 
  • Ajoutez « 2 ; » pour que ce soit l’adresse qui apparaisse ;  puis « Faux » 
  • Fermez la parenthèse.

Formule =RECHERCHEV(F8;Clients!A3:G21;2;FAUX)

En sélectionnant le Client1, l’adresse s’affiche.

Pour pouvoir tirer la cellule vers le bas et l’adapter plus facilement ajouter le signe $ entre les lettres de cette façon =RECHERCHEV($F$8;Clients!$A$3:$G$21;2;FAUX).

Puis tirez. L’adresse apparait sur les cellules suivantes.

Pour faire apparaître le code postal et la ville modifier la formule en remplaçant le 2 par le 3 =RECHERCHEV($F$8;Clients!$A$3:$G$21;3;FAUX) et ajoutez &" "&RECHERCHEV($F$8;Clients!$A$3:$G$21;4;FAUX)

Pour le numéro de téléphone =RECHERCHEV($F$8;Clients!$A$3:$G$21;5;FAUX)

Pour l’email =RECHERCHEV($F$8;Clients!$A$3:$G$21;6;FAUX)

Personnalisez la partie client en fusionnant les cellules E8 à E12, écrivez client à la verticale en sélectionnant clic droit > Format de cellule > Alignement > Orientation 90°.

Sélectionnez ensuite la couleur de remplissage, mettez en gras et blanc pour reproduire la mise en forme du rectangle DEVIS.

Pour que la Référence client apparaisse automatiquement ajoutez la formule dans la cellule C2 sur le même modèle que précédemment : =RECHERCHEV(F8;Clients!A3:G21;7;FAUX)

Passons au tableau chiffré.

  1. Créer le tableau chiffré

Commencez par insérer une ligne qui correspondra à l’intitulé de la prestation.

Créer ensuite un tableau avec les colonnes suivantes « Description », « Quantité », « Prix Unitaire (HT) », « Prix Totale (HT) » et « Taux de TVA ».

Pour créer une liste déroulante de description, sélectionnez l’ensemble de la colonne > cliquez sur Données > Validation des données > Liste

Reportez-vous cette fois à l’onglet « Prestation » et sélectionnez la totalité de la colonne « Description ».

N’oubliez pas d’ajouter la date de validité du devis.

Pour le prix unitaire, utilisez à nouveau la fonction rechercheV selon le modèle =RECHERCHEV(B18;Prestations!B3:D15;2;FAUX) en se reportant au tableau des prestations.

Pour le prix total =quantité*prix unitaire

Enfin, pour le taux de TVA : =RECHERCHEV(B18;Prestations!B3:D15;3;FAUX)

Passez la valeur en pourcentage.

Ajoutons maintenant les cellules de totaux.

Le total € HT correspond à la somme de la colonne du prix total (HT). Vous utiliserez donc la fonction somme classique.

Pour la cellule TVA à 20% entrer la formule : =0,2*SOMME.SI(I18:I20;20%;H18:H20)

Même chose pour la cellule TVA à 5,5% : =0,055*SOMME.SI(I19:I21;5,5%;H19:H21)

Le total € TTC correspond à la somme des 3 cellules au-dessus ; utilisez donc la fonction classique somme.

Enfin, insérer les mentions obligatoires conformément à votre activité et la forme juridique de votre entreprise, notamment la date de fin de caducité du devis, et l’espace signature.

Vous pouvez consulter et utiliser l’exemple.

Après le devis Excel, la prochaine étape sera la création d’une facture excel.

Bon à savoir : Vous pouvez déléguer la comptabilité à un assistant administratif. Si vous téléchargez un modèle, prenez bien le temps de vérifier que toutes les mentions obligatoires sont présentes dans le document et adaptez-le à votre situation.

Vous souhaitez vous concentrer sur l'essentiel ?

Besoin d'accompagnement pour vos tâches chronophages ?

Notre équipe vous aide à identifier les tâches que vous pourriez efficacement déléguer à TheAssistant.
Notre équipe vous aide à identifier les tâches que vous pourriez efficacement déléguer à TheAssistant.
En savoir plus Découvrir TheAssistant
Besoin d'accompagnement pour vos tâches chronophages ?Demander une démo

Autres articles